using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)x([^[]+)\[([^]]+)\]=\[([^]]+)\]";
string input = @"2xMUA Matte Lipstick - Totally Nude[300]=[600]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}