package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+)x([^[]+)\[([^]]+)\]=\[([^]]+)\]`)
var str = `2xMUA Matte Lipstick - Totally Nude[300]=[600]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}