// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d+)x([^[]+)\[([^]]+)\]=\[([^]]+)\]").unwrap();
let string = "2xMUA Matte Lipstick - Totally Nude[300]=[600]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}