$re = '/(\d+)x([^[]+)\[([^]]+)\]=\[([^]]+)\]/';
$str = '2xMUA Matte Lipstick - Totally Nude[300]=[600]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);