import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\{.\\} ?(?:(?:\\[ ?(.+?) ?\\]|\\< ?(.+?) ?\\>) ?)";
final String string = "{c}\n"
+ "{c} [ plugin/theme ID ]\n"
+ "{c} [ plugin URL ]\n"
+ "{c}\n"
+ "{c} [ plugin/theme ID ]\n"
+ "{c}\n"
+ "{c} [ plugin/theme ID ]\n"
+ "{c} [ ...arguments ]\n"
+ "{c} [ commandName ]\n"
+ "{c} [ ...arguments ]\n"
+ "{c} [text to make worse]\n"
+ "{c} any text here\n"
+ "{c} <disable|enable|remove> <id>\n"
+ "{c} [house name]\n"
+ "{c} [type]\n"
+ "{c}\n"
+ "{c} <view|list|add|update|delete> <tagName> [tagContent]\n"
+ "{c} [message id] [channel id]\n"
+ "{c} <id>\n"
+ "{c} [--send] [TEXT | FILE_URL | --clipboard]\n"
+ "{c} [--send] [TEXT | FILE_URL | --clipboard]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}