$re = '/^{.} ?(?:(?:\[ ?(.+?) ?\]|\< ?(.+?) ?\>) ?)/m';
$str = '{c}
{c} [ plugin/theme ID ]
{c} [ plugin URL ]
{c}
{c} [ plugin/theme ID ]
{c}
{c} [ plugin/theme ID ]
{c} [ ...arguments ]
{c} [ commandName ]
{c} [ ...arguments ]
{c} [text to make worse]
{c} any text here
{c} <disable|enable|remove> <id>
{c} [house name]
{c} [type]
{c}
{c} <view|list|add|update|delete> <tagName> [tagContent]
{c} [message id] [channel id]
{c} <id>
{c} [--send] [TEXT | FILE_URL | --clipboard]
{c} [--send] [TEXT | FILE_URL | --clipboard]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);