import Foundation
let pattern = #"^{.} ?(?:(?:\[ ?(.+?) ?\]|\< ?(.+?) ?\>) ?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{c}
{c} [ plugin/theme ID ]
{c} [ plugin URL ]
{c}
{c} [ plugin/theme ID ]
{c}
{c} [ plugin/theme ID ]
{c} [ ...arguments ]
{c} [ commandName ]
{c} [ ...arguments ]
{c} [text to make worse]
{c} any text here
{c} <disable|enable|remove> <id>
{c} [house name]
{c} [type]
{c}
{c} <view|list|add|update|delete> <tagName> [tagContent]
{c} [message id] [channel id]
{c} <id>
{c} [--send] [TEXT | FILE_URL | --clipboard]
{c} [--send] [TEXT | FILE_URL | --clipboard]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)