use strict;
my $str = '{c}
{c} [ plugin/theme ID ]
{c} [ plugin URL ]
{c}
{c} [ plugin/theme ID ]
{c}
{c} [ plugin/theme ID ]
{c} [ ...arguments ]
{c} [ commandName ]
{c} [ ...arguments ]
{c} [text to make worse]
{c} any text here
{c} <disable|enable|remove> <id>
{c} [house name]
{c} [type]
{c}
{c} <view|list|add|update|delete> <tagName> [tagContent]
{c} [message id] [channel id]
{c} <id>
{c} [--send] [TEXT | FILE_URL | --clipboard]
{c} [--send] [TEXT | FILE_URL | --clipboard]';
my $regex = qr/^{.} ?(?:(?:\[ ?(.+?) ?\]|\< ?(.+?) ?\>) ?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}