# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^{.} ?(?:(?:\[ ?(.+?) ?\]|\< ?(.+?) ?\>) ?)"
test_str = ("{c}\n"
"{c} [ plugin/theme ID ]\n"
"{c} [ plugin URL ]\n"
"{c}\n"
"{c} [ plugin/theme ID ]\n"
"{c}\n"
"{c} [ plugin/theme ID ]\n"
"{c} [ ...arguments ]\n"
"{c} [ commandName ]\n"
"{c} [ ...arguments ]\n"
"{c} [text to make worse]\n"
"{c} any text here\n"
"{c} <disable|enable|remove> <id>\n"
"{c} [house name]\n"
"{c} [type]\n"
"{c}\n"
"{c} <view|list|add|update|delete> <tagName> [tagContent]\n"
"{c} [message id] [channel id]\n"
"{c} <id>\n"
"{c} [--send] [TEXT | FILE_URL | --clipboard]\n"
"{c} [--send] [TEXT | FILE_URL | --clipboard]")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.