use strict;
my $str = '4.13723725115740744492e+04,162,1);';
my $regex = qr/[^,]+(?=,162,1\);)/mp;
my $subst = '\'2015-04-02 10:46:28\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";