import Foundation
let pattern = #"[^,]+(?=,162,1\);)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"4.13723725115740744492e+04,162,1);"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"'2015-04-02 10:46:28'"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)