using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^(\/\*)|([ \t'""](\/\*)))(?!\/)(.|[\r\n]|\n)+?\*\/\n?\n?";
string input = @"/* 'aa/' */
/*!test*/
/* someone said 'hello' */
/* ""hello""*/
/***test****/
/******
'test'
****/
/****
test
****/
// let's try a single quote here ""test""
/*
test
*/
/*'test'*/
/*
test
*/
/*
'test ' */
/** @require 'aa/*' */
.test
content ''/* test */
.test content ""/* test */""
.test content /* test */
@require 'aaa/*'
@require 'bbb/*' /* test */
@require 'ccc/*'
@require 'ccc/* ab */' /* test */
@require 'ddd/*' /*test '*/
@require ""ddd/*"" /*test '*/
@require 'eee/*'
// test again
@require 'fff/*'
@require 'ggg/*'
@require 'hhh/*'
@require 'iii/*'
@require 'jjj/*' /*
test */
@require 'kk/**/*'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}