import Foundation
let pattern = #"(^(\/\*)|([ \t'"](\/\*)))(?!\/)(.|[\r\n]|\n)+?\*\/\n?\n?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/* 'aa/' */
/*!test*/
/* someone said 'hello' */
/* "hello"*/
/***test****/
/******
'test'
****/
/****
test
****/
// let's try a single quote here "test"
/*
test
*/
/*'test'*/
/*
test
*/
/*
'test ' */
/** @require 'aa/*' */
.test
content ''/* test */
.test content "/* test */"
.test content /* test */
@require 'aaa/*'
@require 'bbb/*' /* test */
@require 'ccc/*'
@require 'ccc/* ab */' /* test */
@require 'ddd/*' /*test '*/
@require "ddd/*" /*test '*/
@require 'eee/*'
// test again
@require 'fff/*'
@require 'ggg/*'
@require 'hhh/*'
@require 'iii/*'
@require 'jjj/*' /*
test */
@require 'kk/**/*'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)