const regex = /(^(\/\*)|([ \t'"](\/\*)))(?!\/)(.|[\r\n]|\n)+?\*\/\n?\n?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^(\\\/\\*)|([ \\t\'"](\\\/\\*)))(?!\\\/)(.|[\\r\\n]|\\n)+?\\*\\\/\\n?\\n?', 'gm')
const str = `/* 'aa/' */
/*!test*/
/* someone said 'hello' */
/* "hello"*/
/***test****/
/******
'test'
****/
/****
test
****/
// let's try a single quote here "test"
/*
test
*/
/*'test'*/
/*
test
*/
/*
'test ' */
/** @require 'aa/*' */
.test
content ''/* test */
.test content "/* test */"
.test content /* test */
@require 'aaa/*'
@require 'bbb/*' /* test */
@require 'ccc/*'
@require 'ccc/* ab */' /* test */
@require 'ddd/*' /*test '*/
@require "ddd/*" /*test '*/
@require 'eee/*'
// test again
@require 'fff/*'
@require 'ggg/*'
@require 'hhh/*'
@require 'iii/*'
@require 'jjj/*' /*
test */
@require 'kk/**/*'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}