#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^temp(?:_(?:\d{4}_\d\d_\d\d|\d\d_?\d\d_?\d{4}))?\.txt$"
Local $sString = "temp_2023_05_22.txt" & @CRLF & _
"temp.txt" & @CRLF & _
"temp_09_05_2022.txt" & @CRLF & _
"temp_22092023.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")