import re
regex = re.compile(r"^temp(?:_(?:\d{4}_\d\d_\d\d|\d\d_?\d\d_?\d{4}))?\.txt$", flags=re.MULTILINE)
test_str = ("temp_2023_05_22.txt\n"
"temp.txt\n"
"temp_09_05_2022.txt\n"
"temp_22092023.txt")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")