$re = '/^temp(?:_(?:\d{4}_\d\d_\d\d|\d\d_?\d\d_?\d{4}))?\.txt$/m';
$str = 'temp_2023_05_22.txt
temp.txt
temp_09_05_2022.txt
temp_22092023.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);