re = /^temp(?:_(?:\d{4}_\d\d_\d\d|\d\d_?\d\d_?\d{4}))?\.txt$/m
str = 'temp_2023_05_22.txt
temp.txt
temp_09_05_2022.txt
temp_22092023.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end