const regex = new RegExp('^temp(?:_(?:\\d{4}_\\d\\d_\\d\\d|\\d\\d_?\\d\\d_?\\d{4}))?\\.txt$', 'gm')
const str = `temp_2023_05_22.txt
temp.txt
temp_09_05_2022.txt
temp_22092023.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}