# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=\D)\\/(?<=\D)//gm;t' <<< "hello/world
12/hello
hello/12
14/23
"