$re = '/(?=\D)\/(?<=\D)/m';
$str = 'hello/world
12/hello
hello/12
14/23
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;