const regex = /(?=\D)\/(?<=\D)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\D)\\\/(?<=\\D)', 'gm')
const str = `hello/world
12/hello
hello/12
14/23
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);