use strict;
my $str = 'hello/world
12/hello
hello/12
14/23
';
my $regex = qr/(?=\D)\/(?<=\D)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";