#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\\(?!color)[^{}]+?\{(\\(?!color)[^{}]+?\{([^{}])+?\}|[^{}])+?\})"
Local $sString = "text \footnote{foobar} other text \footnote{\cite{citekey1}} text " & @CRLF & _
"text\footnote{\cite{citekey1}; \cite{citekey2}.} text \color{red}text" & @CRLF & _
"" & @CRLF & _
"Doesn't find three layers:" & @CRLF & _
"\footnote{\command{text\cite{citekey1}1}; \cite{citekey2}.}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")