const regex = /(\\(?!color)[^{}]+?\{(\\(?!color)[^{}]+?\{([^{}])+?\}|[^{}])+?\})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\\(?!color)[^{}]+?\\{(\\\\(?!color)[^{}]+?\\{([^{}])+?\\}|[^{}])+?\\})', 'gm')
const str = `text \\footnote{foobar} other text \\footnote{\\cite{citekey1}} text
text\\footnote{\\cite{citekey1}; \\cite{citekey2}.} text \\color{red}text
Doesn't find three layers:
\\footnote{\\command{text\\cite{citekey1}1}; \\cite{citekey2}.}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}