re = /(\\(?!color)[^{}]+?\{(\\(?!color)[^{}]+?\{([^{}])+?\}|[^{}])+?\})/m
str = 'text \\footnote{foobar} other text \\footnote{\\cite{citekey1}} text
text\\footnote{\\cite{citekey1}; \\cite{citekey2}.} text \\color{red}text
Doesn\'t find three layers:
\\footnote{\\command{text\\cite{citekey1}1}; \\cite{citekey2}.}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end