$re = '/(\\\\(?!color)[^{}]+?\{(\\\\(?!color)[^{}]+?\{([^{}])+?\}|[^{}])+?\})/m';
$str = 'text \\footnote{foobar} other text \\footnote{\\cite{citekey1}} text
text\\footnote{\\cite{citekey1}; \\cite{citekey2}.} text \\color{red}text
Doesn\'t find three layers:
\\footnote{\\command{text\\cite{citekey1}1}; \\cite{citekey2}.}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);