using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\\(?!color)[^{}]+?\{(\\(?!color)[^{}]+?\{([^{}])+?\}|[^{}])+?\})";
string input = @"text \footnote{foobar} other text \footnote{\cite{citekey1}} text
text\footnote{\cite{citekey1}; \cite{citekey2}.} text \color{red}text
Doesn't find three layers:
\footnote{\command{text\cite{citekey1}1}; \cite{citekey2}.}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}