#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:abc|defg|hi| )+$"
Local $sString = "abc defg hi" & @CRLF & _
"abc hi defg" & @CRLF & _
"defg abc hi" & @CRLF & _
"defg hi abc" & @CRLF & _
"hi abc defg" & @CRLF & _
"hi defg ghi" & @CRLF & _
"ih defg ghi"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")