const regex = /^(?:abc|defg|hi| )+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:abc|defg|hi| )+$', 'gm')
const str = `abc defg hi
abc hi defg
defg abc hi
defg hi abc
hi abc defg
hi defg ghi
ih defg ghi`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}