$re = '/^(?:abc|defg|hi| )+$/m';
$str = 'abc defg hi
abc hi defg
defg abc hi
defg hi abc
hi abc defg
hi defg ghi
ih defg ghi';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);