// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:abc|defg|hi| )+$").unwrap();
let string = "abc defg hi
abc hi defg
defg abc hi
defg hi abc
hi abc defg
hi defg ghi
ih defg ghi";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}