re = /^(?:abc|defg|hi| )+$/m
str = 'abc defg hi
abc hi defg
defg abc hi
defg hi abc
hi abc defg
hi defg ghi
ih defg ghi'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end