#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^$|^(http(s)?:\/\/([a-zA-Z0-9.-]*)(:\d{0,5})?,?)*$"
Local $sString = "http://192.168.1.100:32400,http://192.168.1.100:32400,http://sasdfds.com" & @CRLF & _
"http://sasd-fds.com" & @CRLF & _
"http://GASGH-ASD.com" & @CRLF & _
"https://sasd-fds.test.long.com" & @CRLF & _
"http://192.168.1.100:32400" & @CRLF & _
"https://192.168.1.100:32400" & @CRLF & _
"http://adomain.com:32400" & @CRLF & _
"https://adomain.com:32400" & @CRLF & _
"https://192.168.1.100:32400" & @CRLF & _
"http://adomain.com:32400" & @CRLF & _
"https://adomain.com:32400" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")