package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^$|^(http(s)?:\/\/([a-zA-Z0-9.-]*)(:\d{0,5})?,?)*$`)
var str = `http://192.168.1.100:32400,http://192.168.1.100:32400,http://sasdfds.com
http://sasd-fds.com
http://GASGH-ASD.com
https://sasd-fds.test.long.com
http://192.168.1.100:32400
https://192.168.1.100:32400
http://adomain.com:32400
https://adomain.com:32400
https://192.168.1.100:32400
http://adomain.com:32400
https://adomain.com:32400
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}