re = /^$|^(http(s)?:\/\/([a-zA-Z0-9.-]*)(:\d{0,5})?,?)*$/m
str = 'http://192.168.1.100:32400,http://192.168.1.100:32400,http://sasdfds.com
http://sasd-fds.com
http://GASGH-ASD.com
https://sasd-fds.test.long.com
http://192.168.1.100:32400
https://192.168.1.100:32400
http://adomain.com:32400
https://adomain.com:32400
https://192.168.1.100:32400
http://adomain.com:32400
https://adomain.com:32400
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end