# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^$|^(http(s)?:\/\/([a-zA-Z0-9.-]*)(:\d{0,5})?,?)*$"
test_str = ("http://192.168.1.100:32400,http://192.168.1.100:32400,http://sasdfds.com\n"
"http://sasd-fds.com\n"
"http://GASGH-ASD.com\n"
"https://sasd-fds.test.long.com\n"
"http://192.168.1.100:32400\n"
"https://192.168.1.100:32400\n"
"http://adomain.com:32400\n"
"https://adomain.com:32400\n"
"https://192.168.1.100:32400\n"
"http://adomain.com:32400\n"
"https://adomain.com:32400\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.