using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[01]?[0-9]|2[0-3])(?::(?:[0-5]?[0-9])?)?$";
string input = @"2
23
23:
23:5
23:59
24:00
00:00
10
9
0
16
24
23";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}