import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[01]?[0-9]|2[0-3])(?::(?:[0-5]?[0-9])?)?$";
final String string = "2\n"
+ "23\n"
+ "23:\n"
+ "23:5\n"
+ "23:59\n"
+ "24:00\n"
+ "00:00\n"
+ "10\n"
+ "9\n"
+ "0\n"
+ "16\n"
+ "24\n"
+ "23";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}