package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[01]?[0-9]|2[0-3])(?::(?:[0-5]?[0-9])?)?$`)
var str = `2
23
23:
23:5
23:59
24:00
00:00
10
9
0
16
24
23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}