use strict;
my $str = '2
23
23:
23:5
23:59
24:00
00:00
10
9
0
16
24
23';
my $regex = qr/^(?:[01]?[0-9]|2[0-3])(?::(?:[0-5]?[0-9])?)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}