$re = '/^(?:[01]?[0-9]|2[0-3])(?::(?:[0-5]?[0-9])?)?$/m';
$str = '2
23
23:
23:5
23:59
24:00
00:00
10
9
0
16
24
23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);