#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<major>[1-9]+\d*)\.(?P<minor>[1-9]+\d*)\.(?P<patch>[1-9]+\d*)(?:-(?P<pre_release>(?:[A-Za-z1-9][A-Za-z0-9\-]*)+(?:\.(?:[A-Za-z1-9][A-Za-z0-9\-]*)+)*))?(?:\+(?P<build_metadata>(?:[A-Za-z1-9][A-Za-z0-9\-]*)+(?:\.(?:[A-Za-z1-9][A-Za-z0-9\-]*)+)*))?$" & @CRLF & _
""
Local $sString = "131.22.33" & @CRLF & _
"131.22.33-a.b-t.c.123" & @CRLF & _
"131.22.33+abc.oio.a-sd" & @CRLF & _
"131.22.33-a.b-t.c.123+abc.oio.a-sd" & @CRLF & _
"131.22.33-" & @CRLF & _
"131.22.33--a.b-t.c.123" & @CRLF & _
"131.22.33+-abc.oio.a-sd" & @CRLF & _
"131.22.33++abc.oio.a-sd" & @CRLF & _
"131.22.33-a.b-t.c.123++abc.oio.a-sd" & @CRLF & _
"131..22.33" & @CRLF & _
"131.22.33-a..b-t.c.123" & @CRLF & _
"131.22.33+abc..oio.a-sd" & @CRLF & _
"131.22.33-a.b-t..c.123+abc.oio.a-sd" & @CRLF & _
"0131.22.33" & @CRLF & _
"131.022.33-a.b-t.c.123" & @CRLF & _
"131.22.033+abc.oio.a-sd" & @CRLF & _
"131.22.33-a.b-t.c.123+abc.oio.a-sd+a.b-t.c.123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")