use strict;
my $str = '131.22.33
131.22.33-a.b-t.c.123
131.22.33+abc.oio.a-sd
131.22.33-a.b-t.c.123+abc.oio.a-sd
131.22.33-
131.22.33--a.b-t.c.123
131.22.33+-abc.oio.a-sd
131.22.33++abc.oio.a-sd
131.22.33-a.b-t.c.123++abc.oio.a-sd
131..22.33
131.22.33-a..b-t.c.123
131.22.33+abc..oio.a-sd
131.22.33-a.b-t..c.123+abc.oio.a-sd
0131.22.33
131.022.33-a.b-t.c.123
131.22.033+abc.oio.a-sd
131.22.33-a.b-t.c.123+abc.oio.a-sd+a.b-t.c.123';
my $regex = qr/^(?P<major>[1-9]+\d*)\.(?P<minor>[1-9]+\d*)\.(?P<patch>[1-9]+\d*)(?:-(?P<pre_release>(?:[A-Za-z1-9][A-Za-z0-9\-]*)+(?:\.(?:[A-Za-z1-9][A-Za-z0-9\-]*)+)*))?(?:\+(?P<build_metadata>(?:[A-Za-z1-9][A-Za-z0-9\-]*)+(?:\.(?:[A-Za-z1-9][A-Za-z0-9\-]*)+)*))?$
/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}