import Foundation
let pattern = #"""
^(?P<major>[1-9]+\d*)\.(?P<minor>[1-9]+\d*)\.(?P<patch>[1-9]+\d*)(?:-(?P<pre_release>(?:[A-Za-z1-9][A-Za-z0-9\-]*)+(?:\.(?:[A-Za-z1-9][A-Za-z0-9\-]*)+)*))?(?:\+(?P<build_metadata>(?:[A-Za-z1-9][A-Za-z0-9\-]*)+(?:\.(?:[A-Za-z1-9][A-Za-z0-9\-]*)+)*))?$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
131.22.33
131.22.33-a.b-t.c.123
131.22.33+abc.oio.a-sd
131.22.33-a.b-t.c.123+abc.oio.a-sd
131.22.33-
131.22.33--a.b-t.c.123
131.22.33+-abc.oio.a-sd
131.22.33++abc.oio.a-sd
131.22.33-a.b-t.c.123++abc.oio.a-sd
131..22.33
131.22.33-a..b-t.c.123
131.22.33+abc..oio.a-sd
131.22.33-a.b-t..c.123+abc.oio.a-sd
0131.22.33
131.022.33-a.b-t.c.123
131.22.033+abc.oio.a-sd
131.22.33-a.b-t.c.123+abc.oio.a-sd+a.b-t.c.123
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)