$re = '/^(?P<major>[1-9]+\d*)\.(?P<minor>[1-9]+\d*)\.(?P<patch>[1-9]+\d*)(?:-(?P<pre_release>(?:[A-Za-z1-9][A-Za-z0-9\-]*)+(?:\.(?:[A-Za-z1-9][A-Za-z0-9\-]*)+)*))?(?:\+(?P<build_metadata>(?:[A-Za-z1-9][A-Za-z0-9\-]*)+(?:\.(?:[A-Za-z1-9][A-Za-z0-9\-]*)+)*))?$
/m';
$str = '131.22.33
131.22.33-a.b-t.c.123
131.22.33+abc.oio.a-sd
131.22.33-a.b-t.c.123+abc.oio.a-sd
131.22.33-
131.22.33--a.b-t.c.123
131.22.33+-abc.oio.a-sd
131.22.33++abc.oio.a-sd
131.22.33-a.b-t.c.123++abc.oio.a-sd
131..22.33
131.22.33-a..b-t.c.123
131.22.33+abc..oio.a-sd
131.22.33-a.b-t..c.123+abc.oio.a-sd
0131.22.33
131.022.33-a.b-t.c.123
131.22.033+abc.oio.a-sd
131.22.33-a.b-t.c.123+abc.oio.a-sd+a.b-t.c.123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);