package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<major>[1-9]+\d*)\.(?P<minor>[1-9]+\d*)\.(?P<patch>[1-9]+\d*)(?:-(?P<pre_release>(?:[A-Za-z1-9][A-Za-z0-9\-]*)+(?:\.(?:[A-Za-z1-9][A-Za-z0-9\-]*)+)*))?(?:\+(?P<build_metadata>(?:[A-Za-z1-9][A-Za-z0-9\-]*)+(?:\.(?:[A-Za-z1-9][A-Za-z0-9\-]*)+)*))?$
`)
var str = `131.22.33
131.22.33-a.b-t.c.123
131.22.33+abc.oio.a-sd
131.22.33-a.b-t.c.123+abc.oio.a-sd
131.22.33-
131.22.33--a.b-t.c.123
131.22.33+-abc.oio.a-sd
131.22.33++abc.oio.a-sd
131.22.33-a.b-t.c.123++abc.oio.a-sd
131..22.33
131.22.33-a..b-t.c.123
131.22.33+abc..oio.a-sd
131.22.33-a.b-t..c.123+abc.oio.a-sd
0131.22.33
131.022.33-a.b-t.c.123
131.22.033+abc.oio.a-sd
131.22.33-a.b-t.c.123+abc.oio.a-sd+a.b-t.c.123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}