#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?P<fulldate>(?P<date>(\d{4}-\d{2}-\d{2}))T(?P<time>(\d{2}:\d{2}:\d{2}(?:\.\d+)?)))(?P<tz>(Z|[\+-]\d{2}:\d{2})?))"
Local $sString = "CAST(N'2016-01-19T15:21:32.59+02:00'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")