use strict;
my $str = 'CAST(N\'2016-01-19T15:21:32.59+02:00\'';
my $regex = qr/((?P<fulldate>(?P<date>(\d{4}-\d{2}-\d{2}))T(?P<time>(\d{2}:\d{2}:\d{2}(?:\.\d+)?)))(?P<tz>(Z|[\+-]\d{2}:\d{2})?))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}