re = /((?P<fulldate>(?P<date>(\d{4}-\d{2}-\d{2}))T(?P<time>(\d{2}:\d{2}:\d{2}(?:\.\d+)?)))(?P<tz>(Z|[\+-]\d{2}:\d{2})?))/m
str = 'CAST(N\'2016-01-19T15:21:32.59+02:00\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end